Jump to content
fjh

REGEN with engine brake Fault????

Recommended Posts

Hey Guys  anyone Know if A 2018 MR mp7  will hold out on a Regen with an active Engine brake Fault ! WE have been Fighting with this asshole thing for a Week! various Codes all satisfied  now! Have replaced ahi  , number 7 and the regulator tweeked to over min spec No Rat Chewed Wires,  still shuts down  on a forced gen 1 minute into it Only fault active is the engine brake! No Brake / Valve in stock!

Just asking

E service is A joke!

Edited by fjh
  • Confused 1

Share this post


Link to post
Share on other sites

Sure it’s not parking brake code? I’ve had a few cut out in the middle of a regen due to intermittent parking brake sensor issues 

Share this post


Link to post
Share on other sites

Thanx Pro  for the suggestion but  Naw! WE will check it again thou  it weren't throwing codes for any other vehicle issues only engine emission  crap! the last thing was a low  pressure issue  that has been corrected with the new regulator were now left with this engine brake code !

Start the REGen  it ramps up the rpm for minute then gives up in typical fashion  and the usual The BLANK STARE from The tech tool!  Instead  Saying  something useful  like this regen was terminated BECAUSE  BLA BLA!   No reason Just gives up! and leaves you guessing Grasping At Straws, Bunch of Crap

ALWAYS leaves you Guessing and throwing Parts at Shit! 

Share this post


Link to post
Share on other sites

Your problem is you bought a new truck! You're supposed to buy em after someone else figured this crap out.

  • Like 1

Share this post


Link to post
Share on other sites
59 minutes ago, JoeH said:

Your problem is you bought a new truck! You're supposed to buy em after someone else figured this crap out.

Jokes on you!  I just work on the junk😣 Oh wait no your right  the Joke is still on me! 😡

  • Haha 1

Share this post


Link to post
Share on other sites

I feel your pain. I just idled my derated Star into the dealer at 3am the other morning. And as if these new engines aren't bad enough....this time the problem was $1800 worth of wire harnesses that the dealer has been poking a test light into and now they are all rotten and failing.

Then I finally find out why this truck has been a lemon all along. It's what they called a "hybrid bastard lemon" It was built with a mix of old and new emission system on this DD15. They had a hell of a time even trying to find the proper replacement harnesses for it.

  • Like 1

Share this post


Link to post
Share on other sites
22 hours ago, fjh said:

Jokes on you!  I just work on the junk😣 Oh wait no your right  the Joke is still on me! 😡

Glad it's not you that's in for the never ending repair bills then! My dad and I are picking up a 1988 rd6882 tri axle with a new frame (guessing 5 years old) new camelback (5 years again...) rebuilt rears (5 years...) a rebuilt 300 horse with a T2070! About the only thing wrong with the truck is duct taped hvac, some mold on the dash, and it's the wrong color.  Price? $21k!  Thats how you buy a truck. 😉

Share this post


Link to post
Share on other sites
2 hours ago, JoeH said:

Glad it's not you that's in for the never ending repair bills then! My dad and I are picking up a 1988 rd6882 tri axle with a new frame (guessing 5 years old) new camelback (5 years again...) rebuilt rears (5 years...) a rebuilt 300 horse with a T2070! About the only thing wrong with the truck is duct taped hvac, some mold on the dash, and it's the wrong color.  Price? $21k!  Thats how you buy a truck. 😉

Yup I Can Be just sad working on it!😡 And Glad I don't own it!😂 Sounds like a decent unit you bought smart move! But  However you can think about new stuff in another way ,your contributing to the economy keeping the money moving! makes the bankers happy , makes the government happy , what could be better!  Your creating jobs for other people! 😎 But  Now you've bought an older unit you are cheating those people!!  But  the government is still happy you'll be able to move thous big piles of money around  for them cheaply while all thous other new trucks are in the shop creating jobs for people,  Its Very selfish of you really .🙄 NOT VERY NICE!    But wise!😉 😁

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Bullheaded said:

Solved my emissions issues. Just got home from picking up my new ride. I forgot how glorious mechanical motors are to drive!

 

So between this and the 2013 Star, I know which one I'll be using most.

Just gotta do a bit of body work where it has been dented in a few spots, some paint and good to go. Plastic wrap is still over all the interior, never been taken off. All the headliner, bunk walls, etc. Only the driver seat bottom cushion and the steering wheel are wore.

003 (Large).JPG

Nice looking truck, how about some more pics and specs?

Share this post


Link to post
Share on other sites

I made a post in the proper place HeavyGunner instead of hi-jacking FJH's thread.

 

You can see it here:

 

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, fjh said:

So just to update this thread with the repair! After making all the faults gone on this unit including a faulty out of the box  engine brake valve GRRRR  Did that job Twice !  Here in lied the issue , if your vehicle is Equipped with GPS you  MAY have to disconnect it prior to a forced or in cab Regen  !!! Yup a week long fight for a  stupid  addon GPS ! quite the piss off! Don't expect Tech Tool to help ya on this It  will give you ZIP ! Just something to be aware of  to try  if your working with this tecked out crap!

We have the same issue at our dealer all of the time. GPS or ELD tied into the data link. It's the first thing we do now when the truck is in triage. 

  • Like 1

Share this post


Link to post
Share on other sites

Not long ago Mack/Volvo came out with a service bulletin on how to correctly tie a Qualcomm/ electronic log to the data link. As Bbigrig said , first thing we do is make sure we’re plugged into the factory harness and not some add on jumper harness that looks like the factory diagnostic plug. 

  • Like 1

Share this post


Link to post
Share on other sites
8 minutes ago, Mackpro said:

Not long ago Mack/Volvo came out with a service bulletin on how to correctly tie a Qualcomm/ electronic log to the data link. As Bbigrig said , first thing we do is make sure we’re plugged into the factory harness and not some add on jumper harness that looks like the factory diagnostic plug. 

It's sucks too because some, especially on the Volvos, come in and the plugs look like the factory data link. Wastes our time having to unscrew the dash to make sure its the factory port. It's usually these low cost ELDs that connect with a phone app we find tucked away in the dash. 

Edited by bbigrig

Share this post


Link to post
Share on other sites

Well it Really sucks when you got a garbage truck that has been working fine for over a year and some @sshole goes and stuffs a gps in after the fact ! Its bad enough you got to chase down rat chewed wiring then to be  scrwewed over by some techy dude puting in an addon unit into the mix! SUCKS THE BIG ONE!

Edited by fjh
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Welcome to BMT!

...The world's best antique, classic & modern Mack Truck support forum! Founded in 2000, BigMackTrucks.com is the place to go for everything related to Mack Trucks!

BMT!

BigMackTrucks.com is owned and operated by Watt's Truck Center, New Alexandria, PA. This forum and it's contents are not affiliated with Mack Trucks, Inc. or Volvo Trucks North America.

×