Jump to content
Moparmike

2001 rd 688s shuts down starts right back up no codes

Recommended Posts

2001 rd just did inframe less then 1000 miles on it..someone replaced the original engine with a 99 e7 427 same engine from factory just different year put new vecm had mack reprogram it to specs truck runs fine then will shut down red x comes on heater blower everything shuts down wait a few minutes starts right back up run 15 min or less shut down no codes what so ever..please help I'm so deep in this truck and not able to run it ..first did it last week ran bout 12hrs no problem then started this

Thanks in advance 

Share this post


Link to post
Share on other sites

Also cruise control is not working now was working..I cant idle the truck up once air pressure builds but could before 

Share this post


Link to post
Share on other sites

Engine position sensor?

My former truck did that to new owner. Cruising down the interstate, shut off, pulled over.

Started right up and rest of the day and several more days fine.

Then one day it happened again. His mechanic changed EPS and all fine,,,over three months now

Share this post


Link to post
Share on other sites

Install a new sensor on front of engine and in ball housing..would that stop the heater and  cruiser from working if so I'll replace them again could have got a bad set

Share this post


Link to post
Share on other sites

The blower motor is shutting ? This is a  sign that the  Accessory relay Is possibly Fubar!

  • Thanks 1

Share this post


Link to post
Share on other sites

10-4, look past high tech solution, record what components are being effected during the power/voltage drop-out event and work backwards to what they commonly share in PDM. 

Share this post


Link to post
Share on other sites

I had one do the same thing. Mine ended up being one of the power relays in dash. 

Share this post


Link to post
Share on other sites

Yes blower motor stops when it shuts down..where can I find this relay at 

2001 rd 688s 

E7 

Thank you guys for your response 

Share this post


Link to post
Share on other sites

The 4 power relays are they the relays in need to be looking at 

Screenshot_20190106-193808_Chrome.jpg

Share this post


Link to post
Share on other sites

The 2001 rd688st I owned for a year had relays in the glove box and a relay/fuse box under the hood, top center on the firewall. It had an etech 400 engine. FJH and co. might be talking about the accessory relay in the dash under the ash tray. On our mechanical Macks,  when you bump your key on it actuates an accessory solenoid in the dash under the ash tray. It powers your gauges, radio, blower, etc. Not sure if the electronic engines use this solenoid too, I expect they do. The last couple I got from Mack are junk, they get hot on our stock truck and stop making contact reliably. Smack it with a screw driver handle usually gets it to engage.

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

This should get you home...……. Attn: Relay 2 distribution flow.

 

 

 

 

 

 

Edited by Mack Technician

Share this post


Link to post
Share on other sites
14 hours ago, Moparmike said:

The 4 power relays are they the relays in need to be looking at 

Screenshot_20190106-193808_Chrome.jpg

yup

Share this post


Link to post
Share on other sites

Took passengers side dash off looked everywhere cant find this relay mack said chrome like a ford cant find it ..1 on driver side firewall but they said that's not it..anybody have a picture just for reference that may help me thanks 

Share this post


Link to post
Share on other sites

accessory relay in the dash under the ash tray

Share this post


Link to post
Share on other sites
Just now, fjh said:

accessory relay in the dash under the ash tray

not sure if they changed this in later years  how ever check under that PLASTIC  panel Three screws and your there! They may have changed to 4 relays as pictured above but the location will likely be similar!

Share this post


Link to post
Share on other sites

The 4 relays are the only thing I've found in here with big hot wires that run back out the truck 

Share this post


Link to post
Share on other sites

K then if the relays got big wires running in and out those are what you need to focus on! power relay #2 look At The chart  it traces back to the blower motor!

Share this post


Link to post
Share on other sites

Mike did you get anywhere with this issue?

Share this post


Link to post
Share on other sites

Good job! 😎

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Welcome to BMT!

...The world's best antique, classic & modern Mack Truck support forum! Founded in 2000, BigMackTrucks.com is the place to go for everything related to Mack Trucks!

BMT!

BigMackTrucks.com is owned and operated by Watt's Truck Center, New Alexandria, PA. This forum and it's contents are not affiliated with Mack Trucks, Inc. or Volvo Trucks North America.

×