Jump to content
Sign in to follow this  
bgblk1968

2006 CH Shake/Rough Idle

Recommended Posts

No codes. Changed cam sensor, checked valve adjustment, fuel pump, return valve, unit pump rollers. Had one cylinder a little weak so replaced one pump and injector. Truck runs and pulls good, just shakes truck at an idle. It's not a big shake and some people don't notice, but you can tell something just is not right. Seems to be worse cold.

Merry Christmas everyone!

Share this post


Link to post
Share on other sites

My 96 CL does the same thing,gotta set the idle rpm just right and then it smooths out nice..

  • Like 1

Share this post


Link to post
Share on other sites

Is the fan out of balance?  I had one of my blades get broke out at the tip and it would shake /vibrate the truck.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, MACKS said:

My 96 CL does the same thing,gotta set the idle rpm just right and then it smooths out nice..

Your PLN (tuned-up) is a smooth as silk compared to the E-Techs. They are a choppy devil till they are under load. Start’em up on a cold morning your neighbor will think you bought a steel kettle drum. 

Edited by Mack Technician
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...