Jump to content
kamp_dogg

Bad DEF fluid, What the?!

Recommended Posts

 

I need some help (or guidance) on a question perhaps someone here has encountered:

I have a trucking fleet (Midwest Motor Express out of Bismark, ND asking for assistance from our "supposed experts", who seem to be stumped.

 

They've seen a lot of DEF sensors saying "bad DEF" when you hook up the laptop, full yellow dash complete with warning lights and all, and I'm curious what could this mean? I am thinking the DEF is fine, and other trucks within the same fleet operate normally, with the same sensors in place. They run Cummins ISX and Volvo D13's. 

Could this be dirt, contamination, or other debris in the DEF lines?

It's usually coming from high volume, high quality truck stops and I'm curious as to what the problem is if not the DEF fluid? (Pilot, Flying J, T/A's)

I've heard there are NOx sensors that are prone to fail and ambient temp sensors in the bumper. Any discussion on this would be useful, considering I know very little on the subject.

 

Share this post


Link to post
Share on other sites

we had an issue with both the pete and kenworth this past week where they both needed the DEF filters changed. 

both trucks have only had DEF put in out of the 2.5 gallon containers at our shop. the pete has 65k miles, the kenworth has 46k miles on it. 

 

once the filters were replaced, the lights went off. 

Edited by tjc transport
  • Thanks 1

Share this post


Link to post
Share on other sites

Good question, I'm seeing issues all over the board. Midwest Motor Express was the most recent. They run around 350 trucks, have said at any given time 1-2 trucks are down due to DEF issues, including "bad def" sensors. Was curious, I know you had seen this in a Liebehr if i recall. 

What I can gather, here is what a "bad def" light could mean:

1 – Water in the NOx sensor

2 – Ambient temp sensor (mounted in the front bumper) is misreading or faulty

3 – Driving with less than a full tank causes the crystallization that can build up and cause slime to build up in the filter. Habitual offenders will see this frequently.

4 -Does it occur only in rainy or dry weather? Water and humidity can cause DEF sensors to malfunction.

5 – Inaccurate DEF guage (causes yellow lights to come on) that is the gauge is reading half full when the tank is empty. From what I understand these are prone to failure. So it is worth checking if there is in fact DEF in the tank.

6- Contamination such as sand or dirt or diesel fuel.

7 – Actual ‘bad def’. The easiest way to determine whether DEF Fluid has been compromised is through color comparison. DEF Fluid should always remain the same color- and if you notice a different hue in your tank then you have contaminated product.

On most trucks, they have a DEF filter. On the Cascadia, for example, there is a little tiny def fluid filter that is in the def line right where it goes into the one-box. It can get a buildup of white slime that inhibits the amount of def going into the chamber and give these sort of codes. Called a def Doser inlet screen, check this first.

Curious, what did you find out when your bad def sensor tripped on the liebehr?

 

Share this post


Link to post
Share on other sites

No Liehberr here with DEF, still in interim 4. Afraid to get the second generation Liehberr Interim 4 because it consumes 8-10% DEF to compensate complete removal of the DPF (brother, it sure is a nice clean/open engine compartment though!).  

The machine Pictured is a Volvo L180H. It simply gave a monitor reading for impurity. I drained everything, flushed, ran some NAPA Ad/Blue through it and switched back. 8K hours and never another issues. Blue paint fixed it I guess? I shot the topside DEF supply through our spectrum and it came out in spec.  

  • Like 1

Share this post


Link to post
Share on other sites

Ah yes...it was the Volvo L180H, I recall you mentioned that once. 

Anyone else have any experiences with bad DEF codes (and how you solved the problem?)

 

Image result for bad DEF dash lights

Edited by kamp_dogg
Wanted to leave post open for additional comments.

Share this post


Link to post
Share on other sites

We have about 40 freightliner cascadias with dd13's.    there area a few that within a few hours if getting def at 2 local pilots the dashes light up and they get codes for bad def.    some guys get it there all the time with no issues.    One guy I trust has the issues all the time.  when he gets def at the loves in Hagerstown, Md no issues.    For some reason if he has to get it at the pilot on 322 in duncannon, Pa within 2-3 hours of driving ,lightsand limp mode. If he runs if for about a week and fills def up at the love's it clears itself out and is good to go.      

 

 

 

Share this post


Link to post
Share on other sites

Our shop has a spectrometer thingy that you can inspect the purity of def. I get a similar code on my truck fairly often and usually after having the code cleared it stays away for 3-6 months before coming back for no apparent reason. 2014 Coronado DD15 282000 miles 8889hrs

forgot to add that I’ve tested the def quality multiple times when this happens and it never has been bad. 

Edited by HeavyGunner

Share this post


Link to post
Share on other sites
1 hour ago, Dirtymilkman said:

We were having trouble around here getting bad def codes AFTER the def tank on the truck gets filled. But, if you don't fill it plum full you wouldn't get a code. If you filled it full, it's say bad def quality. Turned out to be wiring harnesses. Overfilling was actually pushing def into the wiring somehow or something like that. Try filling tanks 3/4 full. 

There could be something to that.    Some places fill the tank at a slower rate.     A higher flow rate would kick the pump off sooner not filling the tank as full as a slower rate.     It only affects certain trucks because they are the ones with the bad harnesses.  Makes sense to me.    We have a bunch of wiring issues.   My last truck was a 2012 and I don't remember how many diffrent harness they had to change.   

Share this post


Link to post
Share on other sites
On 10/15/2018 at 11:27 AM, Mack Technician said:

the operator was filling the DEF tank with fuel, stopped when he realized it, told no one and brought it in with a code and "no idea what's going on".

Our 2015 Pierce Firetruck's DEF fill is over the fuel fill. After this happened a THIRD time, we installed a plate on a hinge with a cotter pin that you physically have to remove to be able to open the plate to get to the DEF cap. The act of having to pull the pin and then flip open a plate seems to be enough to make guys think....so far........

 

  • Thanks 1

Share this post


Link to post
Share on other sites

How do they get the fuel nozzle into the def tank?    Ours have real small openings maybe 1"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Welcome to BMT!

...The world's best antique, classic & modern Mack Truck support forum! Founded in 2000, BigMackTrucks.com is the place to go for everything related to Mack Trucks!

BMT!

BigMackTrucks.com is owned and operated by Watt's Truck Center, New Alexandria, PA. This forum and it's contents are not affiliated with Mack Trucks, Inc. or Volvo Trucks North America.

×