Jump to content

Maxitorque t2070 in a dm690s won’t move


Cllandworks
 Share

Recommended Posts

Hey guys, long time reader first time poster ! I have an early 90’s Mack dm690s rolloff truck with the t2070 . Transmission and clutch were rebuilt and no problems since . The truck sat for about 2 months and now when I put the truck in gear and let the clutch out it won’t move at all , doesn’t even pull the engine down . The range selector will go from high to low but I just get an air sound , not the clunking noise like I am used to . I installed a new range selector on the top back drivers side of the transmission and that didn’t solve anything . Any ideas what the culprit could be ? Thanks ! 

Link to comment
Share on other sites

  • 2 years later...
  • 6 months later...
On 1/24/2021 at 2:54 PM, Johnatan said:

Hello I have the same problem my truck it’s neutralice and only 1st and reverse gear work ... what could be the problem the other gears go in but it’s like if the truck was on neutral 

Did you find out the problem with your transmission??? I have the Maxitorque 7 T2070 and it will only go in 1st and reverse and high side in both but will not engage in any other gears. Just like you said its like its in neutral in those other gears... Could you tell me what you did to get it working... Thanks, Peter

Link to comment
Share on other sites

7 hours ago, 1scout1 said:

Did you find out the problem with your transmission??? I have the Maxitorque 7 T2070 and it will only go in 1st and reverse and high side in both but will not engage in any other gears. Just like you said its like its in neutral in those other gears... Could you tell me what you did to get it working... Thanks, Peter

Sounds like you've got an issue with shifter rails in the main box top cover. There are 3 rails with shift forks connected to each one. One rail and fork for 2nd and 3rd speed, one for 4th and 5th and one for 1st and Reverse. The rails have brackets at the top with recesses. When you move your shift lever its bottom end goes in those recesses. When the tranny is in neutral the recesses lined up so you can move the lever left to right. When you move the lever front (or backwards) it forces the rail it occures in a ditch of to go back (or forward). The rail moves on together with its fork sliding a sliding clutch into a gear and you have a gear shifted. If you in that position try moving the shift lever to a side it wouldn't go since the bottom end of the lever isn't against a ditch in another rail. So you can't shift another gear while you already have one shifted in. What you have now seems like you have the ditches in the rails not aligned. So your lever got locked in 1-R rail and can't get into a neighbouring other rail. You need to remove the cab floor and take off the shifter tower. A small stamped rectangular cover with the shift lever sticking off. Just drive the 4 bolts off and pull the lever. You will see the matter through that opening but I suppose fixing the issue may require to dismount the whole top cover of the main box. Nothing special to do that though excepting cleaning the mounting surfaces and applying silicone sealer or a new gasket.

Никогда не бывает слишком много грузовиков! leversole 11.2012

Link to comment
Share on other sites

Everything Vlad has said just about nails it

I dont/wont use silicone or anything like that as what gets squeezed off on the inside eventually breaks off and gets pumped thru your pressure lubricated gear box getting stuck in the the gears etc preventing the gears fully going and the gears then jump out 

When this happens you have to fully disassemble the gear box just to clean all this crap out 

Dont ask how I know, but I can tell you it is a huge job

 

Paul

  • Like 1
Link to comment
Share on other sites

On 1/24/2021 at 2:54 PM, Johnatan said:

Hello I have the same problem my truck it’s neutralice and only 1st and reverse gear work ... what could be the problem the other gears go in but it’s like if the truck was on neutral 

Thanks guys! I will give it a try and let you know how it goes...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...