Jump to content

2001 mack e7 400 missing and backfiring


Recommended Posts

2001 E7 400 was running fine started to miss and backfire like jake stuck on remove wires to jakes still does it backed off on jake adjustment still missing removed external oil lines evened removed solenoids still missing

Link to post
Share on other sites

what color is the smoke if any ? should be gray blue eye burning type smoke  if compression related. should be gray black fuel related in most cases! 

Link to post
Share on other sites
  • 2 years later...

I’m having the same issue with my 2006 aset engine. It idles fine but when I rev it up to 1200 or more it starts to miss and backfire. It smokes like a freight train and smells like kerosene. How can you tell which injector is bad? I tried breaking the fuel lines while it was running and I notice they all made the truck idle rough.  Do you have to remove each one and will you be able to visual see if it is damaged? Or could it be something else. Please help. 

Link to post
Share on other sites

In your case remove the valve cover and check for broken rocker shaft bolts! Just my opinion! the new engines had an issue in this department !

 

Link to post
Share on other sites

The computer Will likly show a bad pump not the injector!  u still may have a bad pump if you changed an injector! just sayin

  • Like 1
Link to post
Share on other sites
11 hours ago, Macktech20 said:

I just worked on a 99 CH613 that had a bad transfer pump causing a misfire

That is a possibility ! Should show up a low fuel pressure!

Link to post
Share on other sites
  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...