Jump to content
Bradford

98 Etech E7 starts, runs for 3 seconds, then shuts off

Recommended Posts

Just started having issues with CH600. A couple of weeks ago It sputtered on me once. Then on tuesday I was hauling a load of dirt and it sputtered and shut off. Thought it was fuel filters, changed them out and it ran fine until I got down the road a couple miles. My tach then stopped working. Now after towing it home it will start and run for 3 or 4 seconds and shut off still no tach. Also brake lights are stuck on. I've cleaned the cab ground and swapped out some relays. I pulled the ecm off and checked the pins and they are not corroded. Running out of ideas of things to check. Thanks for any help. 

Share this post


Link to post
Share on other sites

/be sure to check it the accesory relay is not dropping out when it quits  check to see  if the heater fan / and wipers still operate 

Share this post


Link to post
Share on other sites

Sounds like low coolant sensor

Share this post


Link to post
Share on other sites

No malfunction light and it will start right back up. For some reason the low air light and alarm stay lit up and buzzing after key power is off

Share this post


Link to post
Share on other sites

there is a big relay in the fuse panel. once bad or when missing this is what it does.

Share this post


Link to post
Share on other sites

The fuse panel in the glove box or on the firewall in the engine compartment? My diagram for the relays and fuses is missing on the glovebox compartment. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Welcome to BMT!

...The world's best antique, classic & modern Mack Truck support forum! Founded in 2000, BigMackTrucks.com is the place to go for everything related to Mack Trucks!

BMT!

BigMackTrucks.com is owned and operated by Watt's Truck Center, New Alexandria, PA. This forum and it's contents are not affiliated with Mack Trucks, Inc. or Volvo Trucks North America.

×