Jump to content
Sign in to follow this  
Bigl62

MP8 throttle response

Recommended Posts

Having what could be related issues. Truck just died while travelling, roll to a stop, check for codes and there’s nothing. Turn the key and the truck starts and runs normal. This has happened twice. 

Then today when bobtailing I had a sluggish throttle/turbo. Then after shutting truck off and restarting it now seems normal again. 

The truck is a 2014 with 760,000 Kim’s on it. 

Share this post


Link to post
Share on other sites

Always start with the battery connections then on to the starter then the firewall pass throughs. Load test each battery separately. Low voltage causes weird problems with the MP engines

Share this post


Link to post
Share on other sites

Sounds logical. Will try this. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

Welcome to BMT!

...The world's best antique, classic & modern Mack Truck support forum! Founded in 2000, BigMackTrucks.com is the place to go for everything related to Mack Trucks!

BMT!

BigMackTrucks.com is owned and operated by Watt's Truck Center, New Alexandria, PA. This forum and it's contents are not affiliated with Mack Trucks, Inc. or Volvo Trucks North America.

×