Jump to content
RobM626

Vibration that 2 mechanics and Mack dealer can’t figure out

Recommended Posts

4 minutes ago, Rob said:

Sorry about that. Try this. Look for high stainless cap nuts in your proper thread size.

See if this one will take you there: https://www.mcmaster.com/#cap-nuts/=1cfi6m6

If not, try this one:

https://www.mcmaster.com/#cap-nuts/=1cfi5z2

Got it ... I was guessing acorn cap nuts ... what finish u think I should use? I bought chrome acorn nuts from Home Depot for my mirors when I replaced the old seized ones and they’re completely rusted already.

Share this post


Link to post
Share on other sites
6 minutes ago, RobM626 said:

Got it ... I was guessing acorn cap nuts ... what finish u think I should use? I bought chrome acorn nuts from Home Depot for my mirors when I replaced the old seized ones and they’re completely rusted already.

304, or 18-8 stainless. 304 is better but I don't think Mcmaster has them. 18-8 will hold up well.

Share this post


Link to post
Share on other sites
1 minute ago, Rob said:

304, or 18-8 stainless. 304 is better but I don't think Mcmaster has them. 18-8 will hold up well.

Thanks so much

Share this post


Link to post
Share on other sites
21 minutes ago, Mack Technician said:

Whadja get? 

2008 mack granite 

E2825741-7FD3-4606-B17D-378D1A7FE6D5.png

Share this post


Link to post
Share on other sites
4 hours ago, Mack Technician said:

:thumb:

I love the granites. And it looks pretty good for an 08 and the mileage is really low. I just hope the injector issue gets resolved and let’s the truck get out and earn it’s keep. I do wish it had an mp8 instead of the 7 but we’ll see how it does

Share this post


Link to post
Share on other sites

I wouldn't disrespect any hard working truck, but the instructor at the Mack Engine training advised the same........to stick close, whenever possible, to the MP8 platform. His opinion seems to echo's yours.

Share this post


Link to post
Share on other sites

Our 2012 mp8 has pretty much been a reliable hard working truck. We have had our fair share of issues with aftertreatment system . Basically replaced whole system twice since 2012. But the motor has treated us well. A water pump and that was basically the extent of repairs besides accessories like fan clutch and air conditioner compressor. 

  • Like 1

Share this post


Link to post
Share on other sites

I had a fly wheel housing that wasn’t square. Now machined and true. Worth a check.

Share this post


Link to post
Share on other sites

Good to hear of the  progress finally,  definately  keep us posted for the end result !

Share this post


Link to post
Share on other sites

Will do... I personally am so curious to know what is actually the problem. For me it’s like trying to find out who really killed Kennedy lol. A good mechanic is really like a detective

Share this post


Link to post
Share on other sites

Well, it's been three weeks now. What'd they find?

Share this post


Link to post
Share on other sites
6 hours ago, d9gdon said:

Well, it's been three weeks now. What'd they find?

The flywheel was destroyed . Replaced it. The clutch was shot AGAIN.it was only wearing on the inside of the paddles. the driveshaft was put of balance so they balanced it and a wheel bearing was bad

now the truck feels worst than before the motor is sending a pulsation that’s traveling through the tranny and rattling the hell out of the gears . The slapping when pressing and releasing accelerator is worst than ever. And my transmission is making horrible growling noises. 

Im trying to find a day that bring it back so he can drop tranny  again, drop oil pan. And check out rears. I’m was so miserable about this situation I did t even post the update . Sorry

Share this post


Link to post
Share on other sites

Bud its been along go And I don't remember the full parts change sheet did you replace the damper!Is it possible we have an over fueling situation on 1 cylinder!

Share this post


Link to post
Share on other sites
7 minutes ago, fjh said:

Bud its been along go And I don't remember the full parts change sheet did you replace the damper!Is it possible we have an over fueling situation on 1 cylinder!

It has a new damper

Since I got the truck back it’s giving me a whole new bunch of symptoms. The whole thing feels like it’s falling apart. The motor has more blow by than usual. It’s shaking more than ever. The tranny sounds like it’s about to blow. My tears feel like they’re screwed. The truck is a rolling disaster right now and I do t know where to start. I think I should light a match and call it a day

i don’t understand how all these things just bombarded the truck in the past 2 weeks. I didn’t have a situation happen where it was like “oh no I blew a rear” or “oh no my tranny blew” it just keeps gradually getting worst to the point the trick is barely driveable

Share this post


Link to post
Share on other sites

well it sounds like ya need to look into the blo by situation that don,t sound good is it puffing at the fill tube? if so you lkly got a bad hole!

Edited by fjh

Share this post


Link to post
Share on other sites
1 minute ago, fjh said:

well it sounds like ya need to look into the blo by situation that don,t sound good is it puffing at the fill tube? if so you lkly got a bad hole!

It’s got light steam in the fill tube/ dip stick

Share this post


Link to post
Share on other sites

That is a bad break. I was hoping that you found the problem and it was something simple.

Wondering out loud that they didn't put the wrong damper on the truck? I guess if that was the case it would have shown up immediately after.

Do the mechanics not road test it after it's been through the shop?

Edited by d9gdon
  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, d9gdon said:

That is a bad break. I was hoping that you found the problem and it was something simple.

Wondering out loud that they didn't put the wrong damper on the truck? I guess if that was the case it would have shown up immediately after.

Do the mechanics not road test it after it's been through the shop?

I personally bought the damper from mack. There was supposedly an update for etech engines . I believe the new one was bigger and has more bolt holes . They said I didnt have to change the hub.

they road tested it this time and told me they think it’s in the motor but they don’t do motor work.

i don’t understand how metals never show up in the oil samples. Blackstone always tells me my numbers are excellent with minimal wear. I’m starting to think these oil analysis’ are full of shit man

and shame on all these mechanics to let me keep dumping all this money into a truck that’s not gonna be worth .02 cents once the motor blows up. After this recent bill the repairs totaled $40,000. I could’ve bought another truck 

Share this post


Link to post
Share on other sites

Have they ran the engine with the transmission out? 

Share this post


Link to post
Share on other sites

Your clutch wear is throwing I big loop in the deal for me. I didn’t go back & read all of it again but a fan clutch will cause a lot of vibration too. Don’t really see that causeing clutch wear like you have though.

Share this post


Link to post
Share on other sites
1 hour ago, 1965 said:

Your clutch wear is throwing I big loop in the deal for me. I didn’t go back & read all of it again but a fan clutch will cause a lot of vibration too. Don’t really see that causeing clutch wear like you have though.

Yea  they ran motor without tranny in and there’s a slight vibration but it’s not as pronounced because it doesn’t have the tranny to travel through 

i replaced fan clutch couple months ago no change.

im bringing the truck back to the last guy that worked on it and he told me he’s gonna drop tranny again and get it dynoed from rebuilder and checked out.. he said he’s gonna drop the oil pan too and see what’s going on up there. Although he won’t be able to fix it BC he doesn’t do motor work. The saga continues

Share this post


Link to post
Share on other sites

has this vibration been there since you’ve owned the truck? I’m not doubting you. Has the engine been into before? 

Share this post


Link to post
Share on other sites
43 minutes ago, 1965 said:

has this vibration been there since you’ve owned the truck? I’m not doubting you. Has the engine been into before? 

No it’s gotten progressively worst after different things that were done to the truck. An inframe was done like 4 years ago . After that the motor ran hotter than usual but ran good. A couple years ago I got hit in my yard with a loader and after I picked truck up from  body shop I noticed my clutch was really soft and I had this spinning noise/vibration. I replaced clutch and then I started getting a slapping/clunking noise Everytime I shifted or pressed realeased accelerator. Shortly after that my cam shaft had two lobes that were shot . Replaced cam and rollers and then the motor never ran right since . Been downhill from there. Since then replaced half the components of the truck with the same problems keep coming back and always getting worst. I used to think it was one thing that the problem was. Now it’s looking like multiple  serious things.

i just changed flywheel. I think that was the cause of the premature clutch failures. Now I’m thinking my rears are what’s causing tranny damage. I think the clunking slapping I’m feeling in the tranny is the rears and it’s sending like shock load to the transmission and the clutch. The motor is a whole another mess now. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...