Jump to content
  • 0
Matt king

Coolant level sensor

Question

I have a 93 Mack model RD690S WITH a electrical malfunction light 1-7 Coolant level sensor. Changed sensor filled coolant tank and light still flashes same code is there something I'm missing? 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Does the sensor screw directly into the radiator or is it in a surge tank up on the fire wall? Also does the sensor have a plug in harness or eyelet and nut style harness

Share this post


Link to post
Share on other sites
  • 0

I’m having the same issue. Replaced the sensor and code won’t go away.  I checked for continuity in the plug and was good. Yet if I use a test light, I can’t seem to get a signal. 

Share this post


Link to post
Share on other sites
  • 0

Yep, need to know how sensor is done and on the second truck question, not Mackpros answer, what model and all do you have, different years, models, makes a difference. 

Share this post


Link to post
Share on other sites
  • 0

305mack is one I’m asking about model, etc

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...