Jump to content
MackGirl352

Gauge Reading Low Oil Pressure

Recommended Posts

2000 Mack vision  cx613 e7 400 gauge reading low oil pressure, no codes, no lights, no shut downs runs fine. Checked oil it's fine...but the gauge reads low oil pressure. Reads low enough where the truck would go into automatic shutdown. Could it be a sensor or a bad gauge?

Edited by MackGirl352

Share this post


Link to post
Share on other sites
Quote

check sensor...unhook and spray with brakekleen to get rid of any oil that may interrupt connection

When was last oil change?

 

Share this post


Link to post
Share on other sites

Where is the oil sensor on the 2000 model? Going to change oil this weekend to see if that helps. 

Share this post


Link to post
Share on other sites

Your best thing to do would be to hook up a mechanical gauge to check oil pressure. Any cheap pressure gauge will work. I believe at idle you need very little oil pressure. How well is the Jake brake working? That's a telltale too if you have low pressure. 

Share this post


Link to post
Share on other sites

If it’s an electronic gauge it’s most likely the oil pressure sender. 

Same thing happened to my gauge not so long ago. 

 

Share this post


Link to post
Share on other sites

The sensor will be on top of the filter housing 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...