wrenching4life

E9 head gasket failure after 2500 miles?

30 posts in this topic

I would replace injector and go from there.    terry:D

1 person likes this

Share this post


Link to post
Share on other sites

Just swap number 8 injector with number 6 and see if the noise follows the injector or stays with the cylinder. 

1 person likes this

Share this post


Link to post
Share on other sites

This is unlikely for you withe Dale's heads but i was pursuing a tick that turned out to be a valve seat dropping.

Share this post


Link to post
Share on other sites

Swap injectors around and see if #7 still does it with another injector and see if the old injector makes the same tick noise in another cylinder.  its likely a bad injector, probably scored.  A good pump shop can fix that pretty easy.

My Francis heads leaked when we first put them on we ran them so they got some heat on them, let it cool down and re torqued and they sealed.  I torqued mine to 240.

Share this post


Link to post
Share on other sites
On 7/15/2017 at 2:46 PM, wrenching4life said:

So I'm thinking because I cracked that injector and the tick stopped. There is obviously still compression, an if it was a fire ring problem wouldn't it still make the tick noise?

So does that mean it's an injector pump or injector failure/ problem? Just trying to figure out what is the next step in diagnosis 

Swap the injector  to the adjacent hole see if it moves to that hole! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now