Deere Mack

New Engine or New Truck?

Recommended Posts

12 hours ago, TeamsterGrrrl said:

That 2008 with an AI427 may have been for export. Or they could have legally used a left over E7 by balancing it's emissions with credits from cleaner engines. Using old engines for export to markets with weak emissions is common- Had an ex-International and current Cummins engineer help me install a new exhaust system on my old TDI a couple weeks back, they both had stories of new old stock engines that didn't meet current emissions requirements here being put in trucks exported to countries with weak standards or installed in military trucks which are exempt.

Stands to reason. We have a complete (OEM) emission cancellation retrofit kit, hardware & software, that can be purchased and installed in our Volvo L180H to convert our 13 Liter for sale over seas. Our company has to show destination of foreign purchase, ship information, misc proofs, etc before it can be purchased.  

Share this post


Link to post
Share on other sites
On 7/15/2017 at 11:28 AM, Deere Mack said:

Realistically what do you guys think this truck should be priced at?  Also does 193,728 miles and 8240 hours sound right?  Salesman swore up and down those weren't roll over miles

as an example of a truck that has NOT sat around idling all day, my 05 T800 Kenworth has 269,243 miles and 5904 hours on it when parked this afternoon.

Share this post


Link to post
Share on other sites
2 hours ago, tjc transport said:

as an example of a truck that has NOT sat around idling all day, my 05 T800 Kenworth has 269,243 miles and 5904 hours on it when parked this afternoon.

Maybe it was just hanging out in the shade listening to the radio with the switch on...lol    I know it's really hard see how the hours are off that much.

Share this post


Link to post
Share on other sites

For a truck that runs in the city a lot 30 MPH or less average is par for the course. At the Postal Service it's even worse- I've seen Macks there with only 400,000 miles but 20,000 hours, even slower average speeds in some of the more congested cities.

Share this post


Link to post
Share on other sites

it had to be a municipal truck, is that what the salesman told you? If so that very well may add up, however uncommon, and be creating the price premium.  There are plenty of muni trucks that sit several days of the week or are bought with taxpayer money and used as a spare.  I remember the township i grew up in had the dealership do all the maintenance work.  Once every other month they would drop it off on a monday and pick it up the next monday...i bet that old girl had low miles

Share this post


Link to post
Share on other sites

Our Gernatt Asphalt truck has a pretty low life speed average. Yours is 23.5, we are at 30.4, tjc is 45.7. It was a short haul aggregate truck. I'm guessing a dedicated route. About 640K miles @ 21K hours.

 

Gernatt.thumb.jpg.50df7ba4c25cedd339612a036fb33651.jpg

Share this post


Link to post
Share on other sites

Same in our business my 2015 has 175000 miles and 8300 hours I'm average 21 MPh 1600 hours of pto time

Share this post


Link to post
Share on other sites
11 hours ago, MackMann85 said:

it had to be a municipal truck, is that what the salesman told you? If so that very well may add up, however uncommon, and be creating the price premium.  There are plenty of muni trucks that sit several days of the week or are bought with taxpayer money and used as a spare.  I remember the township i grew up in had the dealership do all the maintenance work.  Once every other month they would drop it off on a monday and pick it up the next monday...i bet that old girl had low miles

Yes, said it was a County Truck.

Share this post


Link to post
Share on other sites

Well, after an intense search and coming up with mostly used and abused, I just went for the new truck.  Talked myself into it.  So far it's been in the shop three times:

  1. On delivery day, did inspection, power divider wouldn't lock (wasn't even hooked up) and had a bad air leak at tank. Back to shop, fixed.
  2. Got an Allison auto and it started acting up, not shifting properly and throwing codes.  Ends up the wiring harness from dash to trans was damaged during the truck build. Back to shop fixed.
  3.  Discovered rear drive pinion seal was leaking.  Went to fix and discovered bad threads on pinion gear, replaced with new pinion gear and seal.

Not even 2600 miles.  Someone please tell me it gets better...lol

 

 

 

20170921_190313.jpg

20170925_173647.jpg

  • Sad 1

Share this post


Link to post
Share on other sites

 Will it get better. I hope so but likely you are in for a ride.  I would not trust any of these new trucks as far as I could push em. I hope you just found a few simple mistakes and it makes you money...Keep us posted

 

  • Like 1

Share this post


Link to post
Share on other sites

The first month or two is the worst. My buddy bought a new KW and after his fourth trip in with it, the dealer gave him a notebook and said just write all the issues down and we'll deal with it at the next service. But every brand new truck will have breaking in pains. 

Share this post


Link to post
Share on other sites
11 hours ago, Lmackattack said:

 Will it get better. I hope so but likely you are in for a ride.  I would not trust any of these new trucks as far as I could push em. I hope you just found a few simple mistakes and it makes you money...Keep us posted

 

 

9 hours ago, Dirtymilkman said:

The first month or two is the worst. My buddy bought a new KW and after his fourth trip in with it, the dealer gave him a notebook and said just write all the issues down and we'll deal with it at the next service. But every brand new truck will have breaking in pains. 

Lets hope so!   Loving the automatic, but that PTO rattle is driving me crazy!

Share this post


Link to post
Share on other sites

Good luck with your new rig.  It looks good!  Can't help with the PTO rattle but I would add it to the list.  It does seem all brands of new equipment have a bunch of teething problems.

  • Like 1

Share this post


Link to post
Share on other sites

Like that old IHC wrecker!  A silver lining to every cloud.  :lol:

Edited by DailyDiesel

Share this post


Link to post
Share on other sites

my new truck in 05 (auto 375hp cv713) was a pain in the first month as well but it was all stupid stuff like chrome on the bumper was pealing or power window switch broke or random malfunction light for no reason (stopped after the first month or 2). just have to work out a few bugs. the more shit the truck has the more crap can go wrong. thats why the older trucks had very little problems. nothing to break lol but i have to say all the newer trucks that people have that i work with doesnt seem to be that way. its always something. they seem to be very "sensitive" for lack of words. i own a 2000 CL713 427hp now and just the other day a malfunction light went on for the first time in years for a unit pump #5. 20 years old and 600k i think i can toss a new one in and not feel bad about it lol 

  • Like 1

Share this post


Link to post
Share on other sites
22 hours ago, DailyDiesel said:

Like that old IHC wrecker!  A silver lining to every cloud.  :lol:

I knew someone would get a kick out of that.  Talked with the owner, he has plans of an mild restoration.  It sure sounded good..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now