Jump to content
Sign in to follow this  
Brian Wise

Mac cxu613 fan clutch

Recommended Posts

Hello, my name is Brian and am an a/c mechanic. I have a customer with a 2015 cxu613. The problem im having is with the fan clutch not engageing at all allowing the head pressure to sky rocket. I have ran the truck for at least 30 mins and have never seen fan engage. I do have 12v going to it but not sure which wire should have the 5 v computer reference signal. I believe im dealing with a bad fan clutch. Anyone have input that may be helpful to me?

Share this post


Link to post
Share on other sites

The easiest way to check to see if the fan is capable of engaging is to disconnect it from the engine harness and run the engine over 1000 rpm. The fan should fully engage in around 10 seconds, if it doesn't replace the fan drive. Loss of voltage triggers a limp home mode, keep in mind the fan drive will rarely fully engage during normal operation 75 to 80% is normal.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

Welcome to BMT!

...The world's best antique, classic & modern Mack Truck support forum! Founded in 2000, BigMackTrucks.com is the place to go for everything related to Mack Trucks!

BMT!

BigMackTrucks.com is owned and operated by Watt's Truck Center, New Alexandria, PA. This forum and it's contents are not affiliated with Mack Trucks, Inc. or Volvo Trucks North America.

×