Jump to content
Sign in to follow this  
Brian Wise

Mac cxu613 fan clutch

Recommended Posts

Hello, my name is Brian and am an a/c mechanic. I have a customer with a 2015 cxu613. The problem im having is with the fan clutch not engageing at all allowing the head pressure to sky rocket. I have ran the truck for at least 30 mins and have never seen fan engage. I do have 12v going to it but not sure which wire should have the 5 v computer reference signal. I believe im dealing with a bad fan clutch. Anyone have input that may be helpful to me?

Share this post


Link to post
Share on other sites

The easiest way to check to see if the fan is capable of engaging is to disconnect it from the engine harness and run the engine over 1000 rpm. The fan should fully engage in around 10 seconds, if it doesn't replace the fan drive. Loss of voltage triggers a limp home mode, keep in mind the fan drive will rarely fully engage during normal operation 75 to 80% is normal.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...