Jump to content
Danieltravelers

excess black smoke

Recommended Posts

I have a 2009 mack cxu613 with a MP7 with a DPF filter and no DEF fluid. when under load and when not under load it as excess black smoke from the tail pipe. I have already cleaned out the EGR valve and the pipes. I haven't cleaned out the DPF filter yet. its has 568983km but I have no codes. should I b looking into dropping the filter and getting it cleaned next or should b I looking some where else?

Share this post


Link to post
Share on other sites

Is there power or fuel mileage loss? 

Share this post


Link to post
Share on other sites

I also have another one same kind of truck with the same situation except the engine light is on.

the codes I have for this one is

P102 - Boost pressure

P105 - Boost temp

P411 - EGR diff pressure

P412 - EGR temp aftercooler

PP270 - ( I cant find what this is)

P096 - fuel level

Share this post


Link to post
Share on other sites

Look for a burst after cooler hose or cracked after cooler

Share this post


Link to post
Share on other sites

I made an aluminum plate to block off the egr pipe at the mixer. You could do that and run it to eliminate a leaking the valve.

Share this post


Link to post
Share on other sites

no my egr is working properly. I would rather fix it properly then doing a patch job on it. I know my filters will have to cleaned out for sure but does anyone think my injectors could b going bad? would I have a code for injectors if it was going bad or a cracked injector?

my turbo has been changed already and my CAC and egr valve been changed twice.

Share this post


Link to post
Share on other sites

I wasn't suggesting a patch job, just a temporary test rig. Injectors will only set a code if something is wrong with the circuit, so it is possible you could have an injector problem without a code.

Share this post


Link to post
Share on other sites

DPF Restricting flo won't help the situation also the turbo could be stuck it will not throw a code for a stuck turbo either How ever you ve changed it so injectors seems possible! Clean the dpf see if it helps you got to do it anyway Your not going backwards!

 

Edited by fjh

Share this post


Link to post
Share on other sites

@fjh yea I had the dpf sent out to clean already and it failed. The dpf filter is no good. so will have to be looking at getting another dpf for this unit. But I will b having a look at the injectors just in case. but the dpf was part of the problem

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...