Jump to content
JerryB

350 won't start

Recommended Posts

I have a 1998 CH w/350 in it that spins over good but won't start.  Has plenty of supply fuel pressure but nothing going to injectors from pump.

 

It ran fine into wash bay but after its bath it don't want to go.

I've cleaned all wiring harness junctions and cleaned engine to rail ground strap but its a no go.  Is there a fuel shut off selonoid or relay somewhere I'm missing?  Could something have gotten wet in the electrical system?   This is the first time in 1.7 million miles she's failed to go.

Share this post


Link to post
Share on other sites

If you haven't got it running yet , All I can suggest is blowing everything off and checking the ecu fuse 

 

Edited by fjh

Share this post


Link to post
Share on other sites

The ECU controls the injectors The VECU module as well that can cause problems.  if it got wet, wet connectors or worse. Where it is located on your 98  don't know.

 

Share this post


Link to post
Share on other sites

Okay thanks guys I had to make a round with another truck and haven't got back to my problem child yet.  I was thinking it has to be something with the ECM so I'll take your advice and check the fuse and module.  If that doesn't work I'll carry the ECM to the hospital to get it checked.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...