Jump to content
Sign in to follow this  
dexter860

95 CH speedo whacko

Recommended Posts

The speedo in my truck is going whacky starts out fine then after a while the needle will fall down and read about 40 mph slower than I'm going? I replaced the tailshaft sensor, and does the same thing, could it be the speedo itself? Yoke seems tight on tranny, truck doesn't throw any codes, thanks.

Share this post


Link to post
Share on other sites

It's either the speedo itself or the printed circuit board. The printed circuit was a very common replacement.

  • Like 1

Share this post


Link to post
Share on other sites

Ok, its electronic, I'll look into that circuit board deal.

Share this post


Link to post
Share on other sites

It's probably the head itself, my 93 did the same thing. When you pull your old one call your local mack and give them your info and ask what the switch positions need to be, set the switches on the new one and you should be good to go

  • Like 1

Share this post


Link to post
Share on other sites

What he said^^^. No board. Just a head and set the dip switches on the rear. Fairly common and you should have an electronic speedo sensor that ties into V-mac. The switches will be based on tire size, axle ratio etc. The dealer may need your vin and they can cross it over from there.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...