Jump to content
Sign in to follow this  
LAWCON

2009 Allison 4500RDS "Cateyes" jumps in and out of gear

Recommended Posts

Hello we have a 2009 Mack Granite with an Allison 4500RDS. When we start the truck it initially runs fine for 10-15 seconds then the wrench in our push button shift seletor comes on for a bit. It then goes out and eventually the truck tries to jump into gear from neutral then goes back into neutral repeatedly.


Around this time we have a relay somewhere clicking repeatedly for a bit. Eventually we get "Cateyes" in the push button selector on the dash then we get the mode red light on that same selector to come on. We can't move the truck anywhere after so we turn it off for a bit then restart it and it does the same thing.


We have played with most of the connections and they all seem fine. We can't seem to find any breaks or kinks in the wiring anywhere that deals with the transmission. We also get a P0880 code on the push button selector which also triggers multiple codes on the dash. The codes on the dash are saying intermittent data readings.


Thanks in advance,

Lawrence

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...