Jump to content
julisrp

18 Spd Mack not taking gears early when truck is cold "Specially when loaded"

Recommended Posts

I own a 2000 Mack Cl 713 with an 18 spd transmission, since last week the weather has been really cold in Massachusetts and after I warm it up and decide to drive off the transmission makes a weird (like grinding) sound and doesn't take the gears, sometimes I'm able to place the gear but It won't drive (with the gear on it's like it was still in neutral), at the end after a couple of tries and lots of patience I am able to drive off by playing with it, But when I am loaded it is a real Odyssey, today I wasn't able to even work 'cause It wouldn't take any gears when loaded.

Any HELP would be greatly appreciated.

Thanks

Share this post


Link to post
Share on other sites

try locking the power divider in. If it is doing something similiar to what mine did a long time ago. For what ever reason my front axle would just disengage and I would sit there drive shaft spin but nothing going on. lock the rears and go.

Or you got ice in the lines and it can't go into range right. Also had a hard time splitting the gears on my 18. seems to do right the past 3 years now.

Share this post


Link to post
Share on other sites

Welcome to the world of Mack 18 speeds.

  • Like 1

Share this post


Link to post
Share on other sites

If its extremely cold and the problem has only happened yesterday, today and maybe tomorrow, its probably the weather. Maybe the gear oil is extra thick and you have moisture in the air system causing the the synchro to shift slow or stick.

It was -9 here today. We had trucks that wouldnt start and Ishifts/Mdrives that wouldnt shift, trucks not regening. You cant really judge problems when the weather gets this cold.

Share this post


Link to post
Share on other sites

If its extremely cold and the problem has only happened yesterday, today and maybe tomorrow, its probably the weather. Maybe the gear oil is extra thick and you have moisture in the air system causing the the synchro to shift slow or stick.

It was -9 here today. We had trucks that wouldnt start and Ishifts/Mdrives that wouldnt shift, trucks not regening. You cant really judge problems when the weather gets this cold.

That about sums it up. Cold,Cold,Cold. Everything is gonna give you some sort of problem

Share this post


Link to post
Share on other sites

NAPA sells magnetic block heaters, maybe throw one of them on the Trans and hope for the best. I know that's not an answer at all, but it might help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...