Jump to content
Sign in to follow this  
Denny

Erratic Miss In 2001 E-7 427

Recommended Posts

I've got a problem that maybe somebody out there has had and cured. It is totally computerized naturally. It has a distinct ERRADIC miss from about 800 to 1000 rpm. Seems like it smooths out after that, but could just be motor dynamics.Only notice it while stationary. It's got plenty of hp. on takeoff pull, and can't hear any misses.It's got my dealer stumped. Got it 1 yr. ago, has done it since. in the last year they've replaced injectors, run fuel psi.,had all 6 injector pumps out, replaced #6, broken spring keeper. Run the valve clearance,twice, last time found a rocker shaft gaulded, replaced it, flashed the computer, set it to min-max hp. Wierd thing is , it does'nt do it until warmed up. Dealer has talked to the factory, Nowhere to turn. I'm thinking electronics, Please help if anybody has had the same thing, THANKS.

Share this post


Link to post
Share on other sites

We have seen this complaint many times and have also talked to the factory engineering several times. At one time they did have a download for this "rough idle" as they call it but I was thinking it was for 1999/2000 models and the 427 seems to have it worse than any of the other HP's. We have seen it where the whole truck shakes but as soon as you idle it up it goes away. We have never been able to get one to quit doing it. We did put a 100psi fuel valve on one and it helped but other than that no luck here.

Share this post


Link to post
Share on other sites
We have seen this complaint many times and have also talked to the factory engineering several times. At one time they did have a download for this "rough idle" as they call it but I was thinking it was for 1999/2000 models and the 427 seems to have it worse than any of the other HP's. We have seen it where the whole truck shakes but as soon as you idle it up it goes away. We have never been able to get one to quit doing it. We did put a 100psi fuel valve on one and it helped but other than that no luck here.

I've stood beside a couple 99/00 Macks at idle and they sounded pretty rough too...was always told that's just how it is. They ran like a bat outta hell but sounded like hell at idle.

Share this post


Link to post
Share on other sites

we have several of the e tech engines they all do it we also several of the older e 7 engines and you can hardley teel there running nature of the beast we have changed fuel pressure on sometimes it helps

Share this post


Link to post
Share on other sites

Thanks a lot for the replies guys, My 95 just purred right along, but it was MECANICAL pump. Still the best!!! It eases my mind somewhat to know that I'm not the only one that idles rough.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...