Jump to content
gradina67

engine oil overheating

Recommended Posts

I have 2000 cx 460 vision mack truck and problem with oil overheating and coolant temperature is normal,....we put new oil cooler and new oil temperature sensor , truck doing same thing.2 months ago truck was pulling very heavy load through big hills and was overheating because radiator was plug up with same dearth and was throwing antifreeze out , I think from that time something start be wrong with oil...when truck idling oil pressure is under 8 what is very loo and truck shout down.....Did I did something wrong to engine and why is oil overheating...thanks I had 4 mack truck and never have same problem...thanks

Share this post


Link to post
Share on other sites

Put a manual oil temperature gauge on it to confirm it is getting that hot, normally if you see a rise in oil temp you will also see a rise in coolant temperature...

Share this post


Link to post
Share on other sites

check the oil pump maybe when it got hot something started leaking internaly

Share this post


Link to post
Share on other sites

You said you are having low oil pressure, I am thinking a seal or oil ring may be leaking and forcing the oil out causing it to heat, kind of like a hydraulic oil, also when the oil thins from heat it can loose it viscosity traits which can contribute to the low oil pressure. then thinner oil is harder to pump, causing the cycle to repeat, I would have to think there is something with that oil pump or seal.

Share this post


Link to post
Share on other sites

Need to make sure the oil is not getting broke down by fuel mixing in , make sure its not overfull maybe do a oil sample.

  • Like 1

Share this post


Link to post
Share on other sites

Staxx has great advice. You do need to get to the bottom of this, and a lube oil analysis is a great way to start.

Share this post


Link to post
Share on other sites

Also have seen the oil pickup tube screen come off and get sucked up into pump causeing low oil psi and high oil temps.

Share this post


Link to post
Share on other sites

My '01 Vision with the E7 460 had the same issue with the oil temp, not the low pressure though. I borrowed a laser handheld thermometer and checked it on a trip to Chicago. The gauge was over 30deg higher than what the filter/ oil cooler read when I checked it.

Wouldn't surprise me if the pressure gauge was way off too. Can't trust electronic gauges.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...