Jump to content
bbigrig

MP8 Injector cups.......Again!

Recommended Posts

So lets see here.......952,000kms. My 2008 Pinnacle with an MP8 485 is now into its 3rd set of Stainless (connicle) injector cups.

The usual loss of prime and hard starting is the first sign. No miss, ran ok but you could hear that MP lost some of her punch. She also had a rich burning fuel smell at the exhaust.( which only started a few days before we took it in as our shop is swamped right now)

1st set, approx. 500,000kms (switched from copper to stainless under Warranty)

2nd set 720,000kms the dealer only replaced 3 cups. (Cheap warranty buggers!)

3rd set I told the dealer to replace all 6. (At my cost this round)

Turns out 2 of the injectors were as they now call it, "Fretted" (cracks in the injector tip body)

So 2 injectors, 6 cups and almost 4G's later its back on the road.

This truck has been good to us for the most part. Hope these cups don't become a regular every 200,000km thing.

post-4266-0-47595000-1379022052_thumb.jp

Share this post


Link to post
Share on other sites

Theres a guy I know that had a 2009 Rawhide with a MP8 that's had 4 sets. they traded and got a new KW with a Cummins.

Share this post


Link to post
Share on other sites

Volvo/Mack has a new conical cup installation tool. It holds the cup down from the top edge while you sweg the tip. The old tool held the cup down at the same point as the injector was sealing with the cup. The idea is the new tool wont "damage" the sealing area on the cup. I guess we will see, time will tell.

There's also a new cup removing tool that doesnt require tapping threads. It works awesome, 5Xs faster.

  • Like 1

Share this post


Link to post
Share on other sites

Had a 2008 CXU and did the cups at 70000 km and then no problems for as long as I had that truck (735000 km)

Now I have a 2012 CHU and just did the cups and 1 injector a week ago at 420000 km

its like a never ending thing

Share this post


Link to post
Share on other sites

Pulled 2 sets of cups this week the new tool is awesome.

Share this post


Link to post
Share on other sites

We got the new tools last week but havent used them yet. We havent replaced any cups in a while, knock on wood!

Share this post


Link to post
Share on other sites

So I picked up the Pinnacle on Friday and to me it sounded a little strange.....

Almost like it was missing even though with the issues they found (6 cups 2 injectors)it went into the Mack dealer without a miss.

Running out to Ottawa Ont. with 30,000lbs the MP8 would barley get up to 180degF on some big hills.

On the flats it was running below 160degF. Had lots of heat coming from the dash and the outside temp was mid 50'sF

We stopped for coffee twice with the engine hot and both times that MP felt like it lost its prime again for a few seconds on start up.

After unloading and returning empty to the Toronto, Ont. area the engine finally started climbing up around the 190degF mark on some hills. By this time the outside temp was in the mid 60"sF. On the trip back we shut the truck down twice to see if it had the same startup problem and it started fine???? Coolant level was ok the entire time.

With no codes etc..do I have another cup issue? The engine to my understanding is shut down at the unit pumps by the ECM when Ignition is cut.

Otherwise I guess I'm going to be looking at that damn Davco filter housing.

Staxx or Mackpro68....any pointers??? Thanks.

Share this post


Link to post
Share on other sites

There are a lot of other items that will cause hard to start . The overflow valve or return line check valve could be sticking or have debris in it , and there are 2 90 degree fitting at the ecu cooling plate that get clogged with debris , at this point in fuel system fuel is unfiltered. remove and check clean . At your davco filter housing is a check valve on the inlet side ,you can remove inspect. Biggest problem is your dealership have a certified tech working on your truck , I see mistakes in repairs all the time . Most of the time if under warrenty when I find at least 2 failed injectors we replace all 6 .

  • Like 1

Share this post


Link to post
Share on other sites

Thanks Staxx. I have yet to get too far into these MP series engines at our shop. They seem to be doing quite well for the most part.

I Will have a look at the rest of the fuel system.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...