Jump to content
Sign in to follow this  
Truck#1

Jerky Brakes

Recommended Posts

I don't get much braking with moderate pedal pressure but then all of a sudden they grab like a S.O.B. (almost puts me through the windshield). It's the same with or without trailer. What should I look at??? The brake valve assembly on the firewall? I'm just guessing since I don't know. Thanks for your help guys. Rob

Share this post


Link to post
Share on other sites

Are any of the axles locking up? Could be treadle valve or a sticking relay valve to either drives or steer,the crack pressure is off,and you get a sudden burst when it does.,overtightened slacks can do this also to close to drum and when you push a tad harder it'll lck up. Also is this an ABS system or standard system or an old unit with the i beleive is the 1121 system.(never can remember the number,the early 70's antilock system).

Share this post


Link to post
Share on other sites
:mack1: If you hear a rush of air then they lock up, it is the footvalve, just changed one on the R model i am driving. I have seen it before, always have been the footvalve. terry

Share this post


Link to post
Share on other sites
:mack1: If you hear a rush of air then they lock up, it is the footvalve,

Amen.

Been there, Fixed that.

Share this post


Link to post
Share on other sites
Amen.

Been there, Fixed that.

Test or guess did you get that, test or guess that me you are trying on parts and hpeing but nyou need to connect a 100 psi air gage to the application line going to the relay vavle on the rear and to the front axle and check the press from the foot vavle as you posh the foot vavle pedtal down and it should be smooth as the pressure goes up.if it is ok then check the pressure to the chambers from the relay vavle at each axle and it should be smooth as you raise the foot petdal pressure and if it has a bob tail vavle in the rear relay then you will be limited untill you release the triler brakes. the antiskid or abs system will not make this problem. Late model get the blame for too many thins and the system will not cause that problem but a abs modulaion vavle that is bad can be deffective which does the same thing as the relay for the older trucks. glenn

Share this post


Link to post
Share on other sites

The wheels aren't locking up and it is an abs system. No rush of air either.

Share this post


Link to post
Share on other sites

Excuse my ignorance. Is the foot valve behind the firewall ( on a CH) that has a half dozen or so air lines connected to it??? If that is it...what does a replacement cost and how hard is it to replace??? thanks. rob

Share this post


Link to post
Share on other sites
Excuse my ignorance. Is the foot valve behind the firewall ( on a CH) that has a half dozen or so air lines connected to it??? If that is it...what does a replacement cost and how hard is it to replace??? thanks. rob

Yes, It's on the engine side of the firewall on a CH, no it's not hard to replace, but just make damn sure you put all the air lines back on exactly as they were.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...