Jump to content

Recommended Posts

friend of mine has one in a truck that he has had for 5 years and he said it quit building boost the other day it has the turbo mounted on top of the blower and he said it wont pull verry well now. what do you guys think he should look for to try and figure the problem. the turbo feels good it dont have any slop in the shafts and it turns smooth and free and the tube from the turbo to the blower is good with no leaks and it dont have any exaust leaks this is what ive checked.

Link to post
Share on other sites

seals would not efect the boost but a loose air box cover will lose boost.Another thing is any fuel problems that will keep it from getting enough fuel will and also the throdle needs checked to see that it gets full throdle.It should have a rack delay and the piston on it maybe hanging in the housing.But if all that is ok then pull covers and make sure it has a tight rack and if its a VS governor do that with the idle screw back off.If it cant get full fuel it will not build boost and yes the power will be down.

glenn akers

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...