Jump to content
Sign in to follow this  
BAD DOG

E9 Lacking Power

Recommended Posts

:SMOKIE-LFT: MY 92 E9 V8 WITH A ROBERT BOSCH P7184 INJECTION PUMP IS GETTING MORE SLUGGISH ALL THE TIME. IT SEEMS TO LACK POWER IN A CROSS WIND AN IN HILLS EVEN WITH JUST AN EMPTY FRIEGHT BOX BEHIND IT. I WAS WONDERING IF IT MIGHT BE LOSING FUEL PRESSURE UNDER LOAD. IT IS GETTING A LITTLE DAMP UP NEAR THE LIFT PUMP ON THE RIGHT SIDE OF THE INJECTION PUMP. WHEN IT SITS AT AN IDLE AND YOU LOOK IN THE FUEL TANK THERE SEEMS TO BE LOTS OF RETURN FUEL. BUT I AM WONDERING IF THE LIFT PUMP MIGHT BE GETTING WEAK. HAS ANYONE ELSE WITH ONE OF THESE E9's WITH THE BOSCH PUMP EVER ENCOUNTERED THIS TYPE OF PROBLEM . IF SO WHAT WAS WRONG.

Share this post


Link to post
Share on other sites

:SMOKIE-LFT: MY 92 E9 V8 WITH A ROBERT BOSCH P7184 INJECTION PUMP IS GETTING MORE SLUGGISH ALL THE TIME. IT SEEMS TO LACK POWER IN A CROSS WIND AN IN HILLS EVEN WITH JUST AN EMPTY FRIEGHT BOX BEHIND IT. I WAS WONDERING IF IT MIGHT BE LOSING FUEL PRESSURE UNDER LOAD. IT IS GETTING A LITTLE DAMP UP NEAR THE LIFT PUMP ON THE RIGHT SIDE OF THE INJECTION PUMP. WHEN IT SITS AT AN IDLE AND YOU LOOK IN THE FUEL TANK THERE SEEMS TO BE LOTS OF RETURN FUEL. BUT I AM WONDERING IF THE LIFT PUMP MIGHT BE GETTING WEAK. HAS ANYONE ELSE WITH ONE OF THESE E9's WITH THE BOSCH PUMP EVER ENCOUNTERED THIS TYPE OF PROBLEM . IF SO WHAT WAS WRONG.

You have a alotof teat to do before some jumps in here and tells you to start replceing some parts that may not be bad but I can give you a list of test to run just like s real mechanic will have to to tell you the problem

test these things

Check for full throttle

Check fuel pressure to the injection pump under load

set vales

check timing

check the diaphram in the anti puff limter or what ever it is called now

Test the air/air for leaks all the way up to the manifold

check air cleaner

pull both ends off of turbo and check turbo only takes a few seconds

make sure the clutch ant sliping under power

then check boost press. under load and see what that engine family requires

make sure engine is running hot enough

Share this post


Link to post
Share on other sites

Friend of mine has a '85 Superliner E9 V8 that had a similar problem recently.Ended up that one of his fuel lines was collapsing.

Share this post


Link to post
Share on other sites
:SMOKIE-LFT: I ALREADY CHANGED THE DRAW LINE FROM THE TANK TO THE LIFT PUMP. I WAS THINKING OF REPLACING THE OTHERS BECAUSE THEY APPEAR TO BE ORIGINAL . I HAVE SEEN SIMILAR SIMPTOMS ON A CAT. I DON"T THINK IT WOULD BE IN NEED OF A TOP END SET BECAUSE WE OVERHAULED THE ENGINE 1YEAR AGO AND HAVE ONLY PUT ABOUT 30,000 MILES ON IT SINCE. THE TURBO WAS OK WHEN I WAS CHECKED IT A COUPLE OF MONTHS AGO. WHAT I AM WONDERING IF IT MIGHT BE VARNISHING UP FROM THIS NEW LOW SULFER FUEL. I HAVE ONLY BEEN HAVING THIS PROBLEM SINCE I WAS BUYING FUEL FROM THE COMANY I WORKED FOR IN MICHIGAN. THERE FUEL RANGED IN COLOUR FROM GREEN TO BLACK JUST LIKE IT HAD OIL FROM TRANSFORMERS OR USED MOTOR OIL IN IT. I WONDER IF THAT HAD SOMTHING TO DO WITH IT. IT PROBABLY DIDN"T HELP IT ANY. I ALWAYS USE LUCAS FUEL CONDITIONER OR HOWES YEAR ROUND. I LOOKED AT WHAT THEY CALL FOR THE AMOUNT THEY CALL FOR USING AND FOUND THAT I WAS ONLY USING HALF OF WHAT THEY CALLED FOR. SO I THINK IT PRBABLY IS VARNISHED UP. A FRIEND OF MINE HAS A NEW MACHINE FOR CLEANING FUEL INJECTION SYSTEMS ON DIESEL ENGINES. I WAS THINKING ABOUT TRYING IT OUT ON MINE. WOULD IT BE A GOOD IDEA?

Share this post


Link to post
Share on other sites

try change your fuel filter first if you guess about fuel quality!

Share this post


Link to post
Share on other sites
:SMOKIE-LFT: I JUST DID ON THE WEEKEND. I USUALLY CHANGE THE FUEL FILTER WHEN I CHANGE THE OIL AND OIL FILTERS EVERY MONTH. THE AIR FILTER GETS CLEANED EVERY WEEKEND AND CHANGED EVERY THREE MONTHS. I'M PROBABLY DOING THIS MORE REGULAR THEN MOST GUYS DO.

Share this post


Link to post
Share on other sites

check out your puff limiter and it's cylinder... what's going on with boost pressure? pyrometer?

if nothing abnormal you'll have more serious test to do..

Share this post


Link to post
Share on other sites

:SMOKIE-LFT: I LOOKED AT THE PUFF LIMITER OR ANEROID VALVE A COUPLE OF WEEKS AGO. EVERYTHING MOVED FREELY AND THE DIAPHRAM LOOKED OK IT WASN'T TORN . THE PYRAMETER RUNS AT ABOUT 600 GOING ON FLAT GROUND AND DOESN't GO UP TO THE 900 DEGREE UNTIL YOU PULL A GOOD HILL FOR A COUPLE OF MILES. I ALSO CHANGED THE LINE FROM THE ANEROID VALVE TO THE INTAKE MANIFOLD ACOUPLE OF WEEKS AGO TO.

:SMOKIE-LFT: I NOTICED TODAY THAT IT RAN A LITTLE BETTER AND WAS EASIER ON FUEL THAN IT HAS BEEN FOR A FEW MONTHS AFTER I DOUBLED THE AMOUNT OF LUCAS FUEL CONDITIONER THAT I USUALY PUT IN IT.

Share this post


Link to post
Share on other sites
:SMOKIE-LFT: I WAS TALKING TO A PUMP MAN IN BRITISH COLUMBIA CAN. THE OTHER DAY AND TOLD HIM MY TRUCKS PROBLEM. HE DID NOT THINK I HAVE ANY TYPE OF PUMP PROBLEM. HE THOUGHT THAT I MIGHT BE LACKING MANIFOLD PRESSURE NEEDED IN ORDER TO OPEN THE ANEROID VALVE. PROBABLY A SERIOUS LEAK IN THE AIR TO AIR OR THE PIPING OR BOOTS. HE TOLD ME THE ANEROID VALVE ON PUMPS LIKE MINE IF IT OPENS PROPERLY ALOWS FOR THE LAST 25% OF YOUR RACK TRAVEL. THAT SEEMS TO BE WHERE I AM LACKING POWER IN MY LAST 3 GEARS IT IS SLOW TO GET GOING. AND SINCE I HAVE BEEN MESSING WITH IT I HAVEN'T HEARD THE WISTLE OUT OF THE TURBO LIKE IT USED TO. BUT THE TURBO LOOKS OK . TOMORROW I AM GOING TO PRESSURE TEST THE AIR TO AIR AND PIPES AND INSTALL BOOST AND FUEL PRESSURE GAUGES SINCE IT DOES NOT HAVE THEM. HAS ANYONE ELSE EVER HEARD OF THIS BEING A POSSIBLE PROBLEM? I SURE WOULD LIKE TO HEAR FROM YOU. I HOPE I SOLVE THIS PROBLEM SOON. I'VE BEEN USING THIS TRUCK TO PULL A 6 AXLE HAULING STEEL THE LAST COUPLE WEEKS AND SHE JUST WON'T PULL A REAL LOAD. I DIDN'T NOTICE IT AS MUCH SINCE I HAVE ONLY PULLED TANDEM TRAILERS WITH IT SINCE JULY.

Share this post


Link to post
Share on other sites

if you have a air to air problem, turbo, air leaking around manifold your truck must smoke black clearly!

if it's the aneroid valve, no black smoke, no power... just get the info on how this thing work (pretty simple) and test it before doing any big test.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...