Jump to content

Search the Community

Showing results for tags 'ECU'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • The Lobby
    • Introduction Forum
    • Truck Stories
  • General Discussions
    • Antique and Classic Mack Trucks General Discussion
    • Modern Mack Truck General Discussion
    • Mack Truck Q & A
  • Specific Topic Forums for Antique & Modern Trucks
    • Engine and Transmission
    • Driveline and Suspension
    • Air Systems and Brakes
    • Electrical, Electronics and Lighting
    • Exterior, Cab, Accessories and Detailing
    • Fire Apparatus
  • Odds and Ends
    • Odds and Ends
    • Trucking News
    • Other Truck Makes
    • Tractors and Equipment
  • Market Place
    • For Sale
    • Wanted to Buy
    • Feedback Forum
    • Transportation Board
    • Watt's Truck Center
    • Product Announcements & Group Buys
  • Shows and Events
    • Truck Shows and Events
  • Site Related
    • Site Related Topics
    • BMT Wiki Support Topics
    • Test Forum
  • Test Club's Post

Blogs

There are no results to display.

There are no results to display.

Categories

  • Antique & Classic Mack Truck Articles
    • Antique & Classic Mack Info
    • Antique Tutorials and How-To Articles
    • Antique Parts and Service Suppliers
  • Modern Mack Truck Articles
    • Modern Mack Truck Info
    • Modern Tutorial and How-To Articles
    • Modern Parts and Service Suppliers
  • Bulldog Magazine

Categories

  • Antique Mack Trucks 1900-1949
  • Classic Mack Trucks 1950-1989
  • Modern Mack Trucks 1990-Present
  • Other Makes

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Facebook Profile


Twitter


Location


Interests


Spam Protection


Make


Model


Year


Other Trucks

Found 3 results

  1. Dash is displaying code SPN#3695 FMI#9, my books dont show this code anywhere, can anyone tell me what they are? Thanks.
  2. I have a 2009 MRU, I'm having problems with a code that comes up (MID 128 Engine ECU, SID 232 5 volt supply, FMI 4) Inactive #19. The ecm and wiring harness has been changed, and we are still having the same issue with the same code. The truck will run fine for a day, the the CEL comes on and it goes in Derate. We have taking it to dealers and 3 party shops with no luck. Anyone have any suggestions?????
  3. Need this ecu for my ch613. 427 horse..
×
×
  • Create New...

Important Information

We have placed cookies on your device to help customize your user experience here on BMT. You can adjust your cookie settings to your preferences if you like, otherwise we'll assume that you're okay to continue.