Jump to content

BucketTrucker688

Porch Pup
  • Content Count

    78
  • Joined

  • Last visited

Community Reputation

4 Good

1 Follower

About BucketTrucker688

  • Rank
    Old Iron Expert

Profile Information

  • Gender
    Male
  • Location
    poconos, pa

Previous Fields

  • Make
    mack
  • Model
    rd688s
  • Year
    1991
  • Other Trucks
    379 Pererbilt Triaxle Dump

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. I have the mechanical Bosch pump just replaced the solenoids and rocker assemblies and it is still intermittent starting now at 1250 and up rpm. I cannot find any relay there's a circuit breaker for the engine brake but cannot locate a relay ( the spot for it is blank). Seems to be fine before 1200-1300 rpm.
  2. I'm sure this topic is on here some where but I was unable to easily find it. Can a mechanical E7-350 with a dynatard be converted to a Jacobs setup? I'm finding the dynatard is becoming extremely hard to find new parts for.
  3. Dumb question and I'll ask Allentown mack tomorrow but when you buy a reman rocker arm from cat it comes with everything as a assembly, is it the same way with mack or do they sell it all a individual parts???
  4. That would be much appreciated! I guess this scenario is becoming more common as these engines age. Crazy why they would discontinue them though. If you find any let me know Thanks!
  5. I'm in need of a Mack 73GC27D or PAI ELA-3543 lash adjusters I'd like to do all 6 but am being told mack and Pai both discontinued them. Now what do I do?
  6. On my 91 the other day I experienced what I thought was a stuck on engine brake...pulled the valve covers and noticed 4 bent exhaust valve push rods. Also noticed the engine brake solenoids not activating at the same time, the rear solenoid activated way later than the front at a idle. Oil pressure seems to be fine 30+/- psi @ idle. I ran the truck all day and it was fine then at the end of the day in 8th gear (8ll trans) it started sounding like a bad miss or like it needed fuel filters. I didn't really notice it again until I needed to back up loaded up a hill then it got worse from there. I am the only driver of this truck and do not over rev what so ever. I also replaced the cam approximately 150k ago about 9 years ago when I got this truck. I plan on changing the push rods and engine brake solenoids and re adjust all the valves but I'm worried that's not the only thing I need to do.
  7. It works fine below about 1500 then above that it gets starts cutting out as the rpms get higher. Sent from my Pixel 2 XL using Tapatalk
  8. I posted about this topic before but could not find the thread. I have a mechanical E7 350 in a 1991 rd688s. At around 1600 rpm my engine brakes start going intermittent. It's not just one head it's both. I was told to check the relay but low and behold I cannot find any engine brake relay it's blank on my fuse panel. Where the other wires go into the heads to the solenoids there is some oil seapage nothing major but this engine brake cutting out when I need it most is getting ageravating. Any help would be greatly appreciated. I'm getting annoyed trying to chase this down. Sent from my Pixel 2 XL using Tapatalk
  9. Didn’t know if u figured ur truck out my rd is doing same thing leaning towards elephant pads 

  10. The Engine Brake on my 1991 E7 is cutting in and out at higher rpm's with a load on. Is this a sign of something? All the electrical connections look ok on the out side there seems to be a little oil seaping from the plug where the wires go into the head not bad but more than I'd care to see. Sent from my Pixel 2 XL using Tapatalk
  11. If $800 is a good deal or not idk...its probably $1300 or more from mack
  12. Would a Borg Warner S400G073 turbo be too much for a E7-350 to handle? The motor is not turned up at all and has all it's oem parts. There is one for sale locally to me brand new but don't know if it will do me any good. I'm starting to see some oil residue on my v-clamp on my turbo outlet so thinking it may be time. Currently it has a S3a038 turbo on it now. Truck runs good but still seems like it could do better.
  13. Would a relay Valve be the culprit for having nothing happen for the top 1/4 of my brake pedal? I have read a sticky relay Valve will show the symptom of not being able to feather into the brakes but I have 3 relay valves and don't know how to diagnose which it may be. The truck is a 91 rd688s Tri axle dump. I was going to change the foot Valve until I read it may be a relay Valve which looks easier to change than a foot Valve. This makes for a white knuckle ride in the rain when all the brakes want to do is lock up on you and you slide to a stop every traffic light.
×
×
  • Create New...