Jump to content

LilMartian

Puppy Poster
  • Content Count

    27
  • Joined

  • Last visited

Community Reputation

4 Good

About LilMartian

  • Rank
    Mack Field Service Tech
  • Birthday March 4

Profile Information

  • Location
    Tuscaloosa
  • Interests
    Firefightering, motorcycles and my kids,especially the grand daughter

Previous Fields

  • Make
    Nissan
  • Model
    Frontier
  • Year
    98
  • Other Trucks
    Mack’s,Mack’s , macks , oh, boats and Mack’s. I’ve had to learn how to work on valvos

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Most likely the jumper or sensor have gone bad. Ohm the sensor out, if it’s shorted, will be open. Pigtails will corrode in the connector sometimes. Located behind the coolant tank.
  2. Ooohhh, damn, can I come play !!!! Please!!!! I love the old ones !!!! oh , by the way y’all(yes, I said it) I also worked for the first western star dealer in Alabama. Love the old ones, wish I could work on the newer ones, not allowed on the property of the star dealer now, lol!!! long story that had to do with an old kenworth cabin over and a 350 small cam Cummins!!!!
  3. LilMartian

    what motor

    ASET 460hp if has egr cooler and Vgt turbo is an ASET commercial meaning a highway application engine. If it has a straight turbo, which if 2005 should be an ASET AC, will be a ccrs type etech, most likely the AC. As joe suggested, look on the front v/c and data plate reveals all.
  4. Is the shutdown lamp coming on? Red circle with an X in middle, when it does it and may want to make sure it works. Usually 3 Amin shutdown causes are oil pressure, coolant level and temp if turned on. Have seen oil pressure sensors cause the problems and with an rd, the gauge is mechanical with an extra oil psi sensor for the ecm, located on top or side of oil filter housing or stand. What you can try is, unplug the oil psi sensor when it starts to do this, changes the code from a mechanical problem to an electrical and will cause a shut down, but most of the time it will run for awhile. Also, if male lamp comes on and you can catch it when your not driving, flash code by turning cruise on/off switch off and pushing the set down then up and count how many flashes. Maybe that will help figure out problem for you
  5. Also, if, just on the off chance, you pulled the “y” hose from bottom of the pancake oil cooler, they use a screen inside of it and when you removed and didn’t find that screen, it may have gotten in the lower pipe and could cause same effect as the rag issue. Something else to think about. Small possibility that and if you put it back, the rear water line to air compressor from the back corner of the block could have some blockage due to casing materials. Mackpro can attest to that I sure. There is an old bulletin on it and correction is to move the back water line from corner of block around to the water manifold. Also, had one that did similar and ended up finding that the water line from the water pump to compressor had pin holes, sucking air in and had collapsed near the fitting at the water pump. Maybe something else to think on
  6. Just want to show another titan at work and why yes, that is my service truck in front of it!!! Lol. That is a 2007 titan and was carrying a drill to cape canveral a few years ago. I do love playing with my puppy dogs!!!!!
  7. LilMartian

    mp7 mack

    Mass flow - open circuit. It’s that pipe on drivers side that has the 2 sensors sticking up in between the two rubber hoses. If its bad, most likely the temp sensor inside was hit by moisture, ie, water. If you are not loosing coolant, then most likely was condensation which builds up in egr system after it has been ran all day and sits all night. If on the off chance you are loosing coolant and you don’t have any external leaks and can’t find where coolant is going, very possible your egr cooler is starting to leak internally. If you replace the mass flow assembly, pipe with the sensors and it’s small ecm, look and see if the “liquid “ inside is is clear or coolant colored and go from there. There are other reasons for it to code an open circuit, but that is the most common cause. Most of the time, you can run it with the code and it not effect engine op but it can cause odd power issues and even cause the turbo to go stupid intermittently. And before asking, it is an assembly and unless someone that I haven’t heard of yet has done it, you can’t change the sensors, they are welded to the pipe and that pain in the butt lil ecm and sensor are programmed together. Hope that helps
  8. There are lots of places that claim they can do it and I know it can be done, pain is keeping up with whom ever does it to begin with. Check for around northern end of Florida ,( somewhere around the Jacksonville area and can be found , if googled correctly)and that’s as much as I can say due to the fact that , first , I work for one of those “crappy” dealers you referenced and due to that , I have to limit saying whom, because, I like my job which pays my bills and bosses like to look for ways to slap you around. But I was never hear and didn’t say anything but to tell you that it’s against the law to mess with Mother Nature!!!! ( also maybe a name starting with something like, uuiummmm, southern diag) oooppps, I didn’t say that out loud!!!!😱🤭🤫
  9. Another of my 2 cents for y’all. One of y’all are gonna come and beat me up for getting in y’alls conversations, but here goes on the 460- change it to a 427 hp- (I hear this coming) if you will look at torque spec sheets for 460, you will notice that it doesn’t start to really go up until almost 1600 and around 1680-1700ist it drops, straight down. The pain with the etech programming has been, the lower hP, the longer the torque stays up. Something to think about. Also, I didn’t read deeply into the comments about pyrometer reading high, if it is and you notice coolant temp going up in a hard pull but seems ok most other times, look at your exhaust manifold and turbo exhaust housing, if they have a “velvet” appearance, it is a boost leak and if guys have checked your intake system and say nothing is wrong, ask if was checked with test plumbing on the turbo inlet or just checked the inner cooler/cac/air to air. If only cac was checked , check it plumbed at the inlet of the turbo and this is where y’all are ALL gonna think I don’t know the per per verbeial but from a hole in the ground, done heard it. If everything is sealed on your intake and I also mean the air compressor inlet, which comes from the back of the intake manifold to compressor, pull the outlet line from the air compressor with pressure on the intake system and see if you have air leaking. Just had to put a compressor on a ‘99 and customer thought I had lost my ever loven mind until we hit the first hill with 92,000 on, not the first one I ever seen. Y’all can throw the tomatoes toward Alabama and NO, I ain’t no damn football fan. Good luck and sorry if I disturbed y’all
  10. There was a company in Tyler, tx that was repairing vmac ecms and I can’t find number on line now but showing in eBay several m7 modules. Also an option, possible slim one, is check with DEX used parts, this is the Volvo/Mack used parts department. You can find them( I have 2 vmac 2 ecms and nope, don’t ask, one has an rpm issue around 1700, thanks Nick, and the other is my bestest test ecm, sorry) at several bone yards and such. Check with tony at Turbys used truck parts in vina,al. He didn’t have one a week ago but he gets trucks in all the time. Just tell him a Martian sent you.
  11. Just a stupid question..... WHY??? And when you are talking about a big bore, Cat, Cummins, Detroit??? Unless it was ordered with an MP 7, which it probably has an MP 8, the engine compartment is being squished with the 8 due to engine length and that lovely sloped hood. Truth be told, it could handle an ISX and that’s is crammed. I would love to have seen the cxu chassis with stretched hood and an MP 10 shoved in there, oooo the capabilities, lol!!! Good ole 3406 would be rear purty too, but that went with those beautiful super liners. Just had to go an pitch 2 more cents in the pile! Have a good time with it.
  12. Gotcha and by the way, the wastegate part number you want is 172743. If the one you found online is the 171702 p/n, that is a non waste gate turbo. Get your vecu to 12b , 380P4 , which is for throttle response, won’t do anything for engine power but does help somewhat with tps reaction and if the person that is doing the programming is an older Mack “mechanic “, ask him if he knows Mr. Frank in tech support, if so, he might be able to get them to change the engine files as well. ( I didn’t say that out loud) good luck and keep me posted, just curious on how it helps.
  13. As mackpro asked, what’s trans? If manual, possibly switch installed in air line to pto, if Allison , please correct me if I’m wrong, Mackp, then pto signal is controlled to vehicle ecu by trans ecu.
  14. Wondering where you work, you sound as bad as me about mp’s lol , 

    birmingham,al and that’s all I’ll say for the moment 

    1. Mackpro

      Mackpro

      Live in western Kentucky,  around Paducah. Working for a company with a fleet of fairly new Mack’s for about 4 months now. Before this I worked at a Mack dealership for about  30 years. I started there in 1988. 

×
×
  • Create New...