Jump to content

OJ Avery

Porch Pup
  • Content Count

    72
  • Joined

  • Last visited

Posts posted by OJ Avery


  1. I have run into this twice recently and both times it was a bad injector. One is sticking open I believe therefore leaking down quickly. Both of the trucks I did, both ran great no drivability issues and no air bubbles indicating cups. There were no injector codes . Cylinder balance test will show it being off some but not really enough to condemn it on that alone.


  2. I have an odd one. 14 gu712 w/mp7. I'm the 3rd person to work on this so here's the story. Code for def quality. Derate for def quality on the lcd. Sensor was replaced, new def added. Same problem. Not sure what was done by 2nd person. I get it this  morning , no codes, derate for def quality on lcd. Cleared lcd warning with the guard dog. Drove for 20 minutes no problems. parked in my bay, off for about 10 minutes. Turn ignition on , lightning bolt and check engine light and def quality derate on lcd all on. after about 5 seconds lightning bolt goes off, a couple seconds later the check engine light goes off. Again I clear the derate message with the guard dog. No codes. I can't find a learned data reset or an acm reset anywhere in ptt. What is going on with this thing? Thanks


  3. ok, so I measured resistance , pin 4 to pin 27a... .5 ohm. Then pin 86 to 22b... 5.0 ohm. I wiggled the harness no changes. So then with everything connected , ignition on I pressed and held the switch and wiggled the connection at the dash panel and the light came on. So I have it positioned where it'll come on every time (so far ) but what would you recommend. I had my suspicions early on that the dash panel itself was bad. But I don't know what to do now. Should I order a dash unit? If I order a dash panel will it need to be programmed at the dealer?


  4. turckster, I concluded that the instrument panel controls the ground circuit. But you cannot just ground that circuit, you'll pop the fuse. ZDB I felt I should have a lit switch with out the mirrors plugged in. Here is what I have.

    At the switch I have power at terminal 2 with the ign on.

    When you push the switch I have power at term 4 on the switch, and that power goes to term 27a on the instrument panel.

    With ign off I have power at pins 85 and 30 at the mirror heater relay. With the relay plugged in I have power at pin 86 at the relay which sends power to pin 22b at the instrument panel.

    I have continuity from pin 12 on the switch to the positive at the mirror. The Ground at the mirror is good.

    ALSO.... I took the dash, the relay and the switch and installed them all separately in another 2013 gu and every time the heated mirrors worked.

    I'm so lost on this


  5. I have an odd one. I'm doing a mirror upgrade for our plow trucks that use a tow plow. Swapping the right stationary mirror for a motorized one. Both left and right mirrors heated of course. The heated mirrors won't operate. I unplugged both to see if the switch would light and it did....1 time. I pulled up the wiring diagram and everything I see is checking out. I have power to the switch at #2. When I press the switch #4 terminal lights like it should. I swapped the relay with another one with exact part number. The HTD mirror fuse at f15 is good. I replaced the switch just because I have one. Any help would be appreciated.


  6. So everything seemed to go well until last week. I heard from the residency mechanic that when its got a full load it shifts hard 1-2 and there's a code for a solenoid. Haven't seen the truck yet, will keep you updated. Thanks for all your efforts, I appreciate you all!!


  7. Thanks BC Mack and Mack Pro. I contemplated sending the cooler out for pressure testing because even though I didn't know what the pressure at the cooler typically was, I knew I wouldn't be able to simulate it. But I went with a new cooler. Second try of course. I ordered everything before I took it apart, I ordered a 7 plate and this has a 17 plate cooler. Yes the cooler is below the output shaft. We've started servicing the Allison's here, and typically anything more than that we send to a Allison dealer, but I figured this wasn't a complicated process so we decided to keep the truck here. We have a couple hundred 13-15 Mack GU with the Allison and we've experienced very few problems.  Thanks again , I can always count on both of you to help out.


  8. Hello??..is this thing on lol?? another question, I am having no luck finding any literature on this thing. I pulled the cooler and put it in the parts washer tank and put about 30# of air to it , no leaks. what is the typical pressure running through the cooler??

×
×
  • Create New...