Jump to content

rvi

Puppy Poster
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

0 Neutral

About rvi

  • Rank
    Engine Started

Profile Information

  • Location
    Va

Previous Fields

  • Make
    mack
  • Model
    freedom
  • Year
    2002

Recent Profile Visitors

946 profile views
  1. I'm tracking down something I will report on tomorrow hopefully. Getting closer... The reverse light and anti theft/immobilizer fuse checks out, unfortunately.
  2. Brilliant! I feel like I am getting closer and closer. Huge thanks again Mackpro!
  3. I think I am definitely getting somewhere! A massive thanks to Mackpro! He sent me advice and manuals, plus one of the message codes was cracked, the EECU Failure 58 Refers to degraded or absent information from the CAN bus line going to (or from?) the EECU. Since the immobilizer does send data to both the EECU and the VECU, it's possible the immobilizer is not working. Or the CAN bus line is cut somehow. Both possibilities will be checked. Thank you all for your help!
  4. You may be onto something, as when I tried to attempt the manual method to input the 4 digit anti theft immobilizer code, the anti theft light on the instrument cluster did not flash at all. Zero response! I will recheck the reverse light fuse, and test the plug at the anti theft unit making sure it is getting power.
  5. Excellent information! I am still reading the document in detail as time permits, but I scanned the whole thing. Now I have confirmed what I thought AT meant, Anti Theft or the immobilizer. It seems I need to reprogram the key with the code from the vehicle document? I wish I knew what "failure 58" means as I did not find any reference to 58 or a 5-8 in the document manual.
  6. Thanks for sharing! I will dig all throughout it, and report back. Interesting regarding the manuals. Two more than I have!
  7. Thanks for the reply, and I appreciate you trying to help! By chance, does your shop still have any of the manuals? I rechecked the codes after a hard battery reset/disconnect, and the same messages pop up. I should add the there was a blink code, it is the picture of a key and the letters "AT" as I wrote in the first post. I just did not consider it a blink code, but going through the gauge cluster it does read that is a blink code. Also, the gauge cluster's self test appears to function. I did go through the entire owners manual as well (zero help with the codes), and the truck does seem to have vmac III.
  8. My truck will not crank over at all. The heater grid light will light then go out as normal, but turning the key further does not start the truck, except for a relay click under the dash. It is a 2001 Freedom XXL. I am getting error messages as follows: VECU 0 00629 31 127 Also EECU failure 58 And finally A photo of a key with the letters "AT" There are no blink codes, as nothing is blinking. The truck ran perfectly when I last drove it, but I removed the batteries to properly recharge them since I was away for awhile. The fully charged batteries were placed back in the truck, only to result in a no crank situation. I checked all the fuses I could find, and none are popped. Does anyone have an idea what may be wrong? Is the photo of the key for an immobilizer? I searched for an explanation of the error messages, and found nothing. Thanks! (I posted this in another section, but this section may be more correct. Apologies in advance)
  9. My truck will not crank at all. The heater grid light will light then go out as normal, but turning the key further does not start the truck. It is a 2001 Freedom XXL. I am getting error messages as follows: VECU 0 00629 31 127 Also EECU failure 58 And finally A photo of a key with the letters "AT" There are no blink codes, as nothing is blinking. The truck ran perfectly when I last drove it, but I removed the batteries to properly recharge them since I was away for awhile. The fully charged batteries were placed back in the truck, only to result in a no crank situation. I checked all the fuses I could find, and none are popped. Does anyone have an idea what may be wrong? Is the photo of the key for an immobilizer? I searched for an explanation of the error messages, and found nothing. Thanks!
×
×
  • Create New...