loweredf1

Low Oil Pressure

7 posts in this topic

recently rebuilt our e7-350 and had a hard time running the overhead but believe we got it right. anyway problem now is oil pressure when warm is showing >15psi at idle and jake barely makes any noise sometimes none. we did not change pump during rebuild because it checked out good. well today we went and got a 500 pump and pickup put it in and no differnce. so my question is could the overhead adjustment cause low oil pressure? or any other ideas? we checked every bearing clearance during assembly and everything was in spec.

Share this post


Link to post
Share on other sites

recently rebuilt our e7-350 and had a hard time running the overhead but believe we got it right. anyway problem now is oil pressure when warm is showing >15psi at idle and jake barely makes any noise sometimes none. we did not change pump during rebuild because it checked out good. well today we went and got a 500 pump and pickup put it in and no differnce. so my question is could the overhead adjustment cause low oil pressure? or any other ideas? we checked every bearing clearance during assembly and everything was in spec.

Check the end of the rocker shafts and make sure there are plugs in the ends they tend to pop out on these engines.The valve set likly has no connection to your problem!

Share this post


Link to post
Share on other sites

My E-7 350 has always had low oil pressure at idle,about 12 lbs,everyone I know says the same thing about the e-7,mack says that is whithin spec and no problem that's the way they are.

Share this post


Link to post
Share on other sites

My E-7 350 has always had low oil pressure at idle,about 12 lbs,everyone I know says the same thing about the e-7,mack says that is whithin spec and no problem that's the way they are.

Yea dont worry till it goes below 10 PSI at hot idle, its common.

Share this post


Link to post
Share on other sites

we just expected more on a fresh rebuild. i will check the rocker shaft plugs

On the Etech style engines they do make a high volume oil pump that helps. On the older E-7's I dont know. I think the oil pump on the Etech style engines turns backwards compaired to the older E-7's. I know the auxilary shaft turns different because the P/S pumps that bolt on the front timing cover wont interechange, found out the hard way!

Share this post


Link to post
Share on other sites

well put a pressure gauge on and appeares our gauge is reading correct. called mack and got their pressure stats we are running a lb or two below spec at idle good in mid range and a little over spec on the top. i guess we are just going to run it and try to keep idle time to a minimum

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now