Jump to content

  •  

  • Welcome to BigMackTrucks.com

    Welcome to BigMackTrucks.com, the best resource on the Internet for Antique, Classic and Modern Mack Trucks!  

     

    Please login or register to take advantage of everything BMT has to offer.  Memberships are Free and offer many benefits:

     

    • Start new topics and reply to others
    • Subscribe to topics and forums to get automatic updates
    • Showcase your trucks in our Garage
    • Photo Gallery, Member Blogs and much more...
    • Add events to our community calendar
    • Create your own profile and make new friends
    • Customize your experience!
    • Mack Dealer and Corporate personnel can contact the ADMIN after registration for access to the Dealer Forums.

    If you are having trouble logging in or haven't received your validation email, you can post as a guest in the Guest Forum.


    login  register
    Guest Message by DevFuse
     

    Photo

    2004 Ai 427 Motor



    • Please log in to reply
    3 replies to this topic

    #1 OFFLINE   jjcutter

    jjcutter

      Rookie

    • Puppy Poster
    • Pip
    • 2 posts

    Posted 08 December 2009 - 01:32 PM

    new to us 2004 mack vision with the 427 engine, issue is when you let off the throttle seems that the jake brake always come on a little, then when you get back into the throttle, it makes two belching kind of noises and then take back off, almost like it is missing out. Also does not have the power of or 98 427. Any help would be appricated

    #2 OFFLINE   Mackpro68

    Mackpro68

      BMT Certified Know-It-All!

    • Pedigreed Bulldog
    • PipPipPipPipPipPipPipPipPipPip
    • 1,193 posts
    • Location:Western Kentucky

    Posted 08 December 2009 - 05:48 PM

    new to us 2004 mack vision with the 427 engine, issue is when you let off the throttle seems that the jake brake always come on a little, then when you get back into the throttle, it makes two belching kind of noises and then take back off, almost like it is missing out. Also does not have the power of or 98 427. Any help would be appricated

    If the engine has the "powerleash" engine brake, the o-rings on the engine brake solinoids could be bad/cut and causing oil leaking into piston area and slightly applying brake. We have seen this before quite often. As far as the low power, read some of the posts on the 460 HP CV's and about going to the dealer to get both ECU's reflashed with the new software for poor throttle responce. Need last 6 of the vin and I can tell you if it need the new software.

    #3 OFFLINE   Mackpro68

    Mackpro68

      BMT Certified Know-It-All!

    • Pedigreed Bulldog
    • PipPipPipPipPipPipPipPipPipPip
    • 1,193 posts
    • Location:Western Kentucky

    Posted 08 December 2009 - 05:51 PM

    new to us 2004 mack vision with the 427 engine, issue is when you let off the throttle seems that the jake brake always come on a little, then when you get back into the throttle, it makes two belching kind of noises and then take back off, almost like it is missing out. Also does not have the power of or 98 427. Any help would be appricated

    Also does it have a auto shift or ultrashift trans? If so the engine brake will engage to help the trans shift even if you got the brake turned off.

    #4 OFFLINE   jjcutter

    jjcutter

      Rookie

    • Puppy Poster
    • Pip
    • 2 posts

    Posted 08 December 2009 - 10:14 PM

    Also does it have a auto shift or ultrashift trans? If so the engine brake will engage to help the trans shift even if you got the brake turned off.

    no has a 10 speed, any ideal about what would cause the beleaching and missing when you get back in the throtle




    0 user(s) are reading this topic

    0 members, 0 guests, 0 anonymous users